Computación en la actualidad

Computación en la actualidadManuel Sepúlveda

Computación en la actualidad

En la actualidad, los avances en las tecnologías aun siguen abrumando a muchos, no solamente vemos cambios en nuevos equipos electrónicos, si no que la conectividad entre personas, trabajo y lugares están ligadas a la tecnología.

Para postular a un trabajo, el típico diario de domingos paso casi a segundo plano, este es intercambiado por sitios con miles de empleos que se ajustan a tu oficio, horario, salario, etc. La tecnología avanza y con ello, se lleva todos los procedimientos a su paso; lo que se hacía antes con filas, encargos y dinero en efectivo, ahora lo hacemos desde una página web, pago en línea y un envío a tu domicilio.

Soy una fiel creedora que la tecnología no es solo para las «nuevas generaciones», si no que, el que desea aprender de ella lo puede hacer. No hay excepciones de edad ni condiciones físicas, la tecnología se adapta al ser humano que la esta utilizando y a su condición. Cada día, los que estamos relacionados con el área tecnológica. nos preocupamos de estar a la vanguardia de ella, siendo disciplinados al momento de capacitarnos, aprender y potenciar la nueva herramienta entregada.

Mi mayor impulso de hacer clases de computación, fue poder integrar a todas las personas que lo requieran al mundo de las computadoras, la adaptabilidad al potencial de Internet y transferir cada conocimiento para que esa persona no se quede afuera de todo lo que esto puede ofrecer, si no que mas bien, se una y pueda aprovechar cada oportunidad que las tecnologías nos pueden brindar.

 

Daniela Sepúlveda, Profesora de EclassVirtual.com

Daniela Sepulveda

 

Plataforma de Administración de red Cisco DNA Center – CCNA 200-301

Plataforma de Administración de red Cisco DNA Center – CCNA 200-301Manuel Sepúlveda

Cisco DNA Center es un centro de administración de red y comando para aprovisionamiento y

Configuración de dispositivos de red.

 

Es una plataforma compuesta por hardware y software que proporciona un único Dashboard que se centra en la garantía, el análisis y automatización.

La página de inicio de la interfaz de DNA Center ofrece un resumen del estado instantáneo de la red, como se muestra en la siguiente figura.

 DNA Center Dashboard

En la parte superior de la pantalla se observa cada uno de los menús que brinda acceso al DNA Center, y que son:

Diseño: modela toda tu red, desde sitios y edificios a dispositivos y enlaces, tanto físicos como virtuales, en campus, sucursales, WAN y nube.

 DNA Center Diseño CCNA 200-301

 

 

Política: utiliza políticas para automatizar y simplificar la gestión de la red, reduciendo costos y riesgos mientras acelera la implementación de nuevos servicios y mejorados.

 DNA Center Politicas CCNA 200-301

 

 

Provisión: Brinda nuevos servicios a los usuarios con facilidad, velocidad y seguridad en toda la red empresarial, independientemente del tamaño y la complejidad de la red.

 DNA Center Provision CCNA 200-301

 

Garantía: utilice la supervisión proactiva y los conocimientos de la red, los dispositivos y las aplicaciones para predecir problemas más rápido

 DNA Center Garantia CCNA 200-301

 

 

Las funciones de Cisco DNA Center se centran en simplificar el trabajo realizado por empresas, con el objetivo de reducir los costos y de implementación. Algunas de las funciones exclusivas de Cisco DNA Center incluyen los siguientes:

 

EasyQoS: permite la implementación de calidad de servicio (QoS) con solo unas pocas opciones simples de Cisco DNA Center.

Análisis de tráfico cifrado: utiliza algoritmos para reconocer las amenazas de seguridad incluso en el tráfico cifrado.

Dispositivo 360 ​​y Cliente 360: brinda información completa (360-grados) de la salud del dispositivo.

Network Time Travel: muestra el rendimiento anterior del cliente en una línea de tiempo para comparar con el comportamiento actual.

Path Trace: descubre la ruta real que los paquetes tomar de origen a destino, basado en las tablas de reenvío.

Los planos de Datos, Control y Gestión para el CCNA 200-301

Los planos de Datos, Control y Gestión para el CCNA 200-301Manuel Sepúlveda

El plano de datos

 

Se refiere a las tareas que un dispositivo de red hace para reenviar un mensaje, determina cómo los datos entrantes a un router son reenviados una salida del router.

El plano de datos a menudo se denomina el plano de reenvío y en la siguiente lista se detallan algunos de las acciones más comunes que realiza un dispositivo de red que encajan en el plano de datos:

■ Desencapsular y volver a encapsular un paquete en una trama de enlace de datos

(routers, switch de capa 3)

■ Agregar o eliminar un encabezado de enlace troncal 802.1Q (routers y switches

■ Hacer coincidir la dirección MAC de una trama Ethernet a la tabla de direcciones MAC (switches de capa 2)

■ Hacer coincidir la dirección IP de destino de un paquete IP con la tabla de enrutamiento IP

(routers, switches de capa 3)

■ Cifrar los datos y agregar un nuevo encabezado IP (para procesamiento de red VPN)

■ Cambiar la dirección IP de origen o destino (para el procesamiento de traducción NAT)

■ Descartar un mensaje debido a un filtro (listas de control de acceso [ACL], puerto seguridad)

 

El plano de control

 

El término plano de control se refiere a cualquier acción que controla el plano de datos. La mayoría de estas acciones tienen que ver con crear las tablas utilizadas por el plano de datos, tablas como la Tabla de enrutamiento IP, un protocolo de resolución de direcciones IP (ARP), una tabla de direcciones MAC, etc.

 

Veamos un ejemplo:

 

 Los planos de Datos, Control y Gestión

 

En la figura, Enhanced Interior Gateway Routing Protocol (EIGRP), el protocolo del plano de control se ejecuta en cada enrutador (es decir, se distribuye entre todos los enrutadores).

EIGRP en cada enrutador se agrega, elimina y cambia la tabla de enrutamiento IP de cada enrutador. Una vez poblada con rutas útiles, la tabla de enrutamiento IP del plano de datos en cada enrutador puede reenviar paquetes entrantes, como se muestra de izquierda a derecha en la parte inferior de la figura. La siguiente lista incluye muchos de los protocolos de plano de control más comunes:

 

■ Routing protocols (OSPF, Enhanced Interior Gateway Routing Protocol [EIGRP], Routing Information Protocol [RIP], Border Gateway Protocol [BGP])

■ IPv4 ARP

■ IPv6 Neighbor Discovery Protocol (NDP)

■ Switch MAC learning

■ STP

 

El plano de gestión

 

El plano de gestión también realiza trabajos generales, pero ese trabajo no impacta directamente en el plano de datos. En cambio, el plano de gestión incluye protocolos que permiten a los ingenieros de red administrar los dispositivos.

Telnet y Secure Shell (SSH) son dos de los protocolos del plano de gestión más conocidos. El siguiente ejemplo muestra el plano de gestión, con varios protocolos del plano de gestión.

 Los planos de Datos, Control y Gestión 02

Como configurar un Wireless Router en Cisco Packet Tracer

Como configurar un Wireless Router en Cisco Packet TracerManuel Sepúlveda

Configuración de Wireless LAN

 

 

 

Laptop0

Lo primero que vamos a realizar es el cambio de la tarjeta NIC en el Laptop0. Por default la NIC instalada es una FastEthernet, la que cambiaremos por una wireless adapter module (WMP 300N)

Antes de cambiar de NIC se debe apagar el Laptop y luego encenderlo

 

PC1

Este PC nos servirá para conectarnos de forma remota al Wireless Router, aunque se puede hacer de forma directa en Packet Tracer.

Pondremos los siguientes parámetros de configuración:

Realizarnos un ping para saber si llegamos al Wireless Router desde el PC1.

Por default la dirección IP del Wireless Router es la 192.168.0.1

 

Entonces nos conectamos al Wireless Router por Web Browser, nos pide “User Name” y “Password”, ambas son admin

 

De forma inmediata nos muestra el GUI del Wireless Router, donde podemos ver la sección de Setup y donde configuraremos lo siguiente:

 

Configuración de Wireless Router

 

Setup:

En Internet Setup –> Automatic Configuration – DHCP

Network Setup –> Ip Adress 192.168.0.1, Subnet Mask 255.255.255.0, DHCP Server Enabled, Starp IP Address 192.168.0.100, Maximum number of Users 50, DNS 172.16.0.100

Como se muestra en la siguiente figura:

 

En la siguiente sección vamos a configurar los parámetros básicos y de seguridad del Wireless

 

Wireless / Basic Wireless Settings

2.4 Ghz –> Auto

Network Mode –> Auto

Nertowk Name (SSID) –> Gerencia

SSID Broadcast –> Enabled

Standard Channel –> 6 – 2.437Ghz

Channel Bandwidth –> Auto

 

Como se muestra en la siguiente figura:

Wireless / Wireless Security

2.4 Ghz

Security Mode –> WPA2 Personal

Encryption –> AES

Passphrase –> eclassvirtual

 

Como se muestra en la siguiente figura:

Laptop0

Volviendo a nuestro Laptop0, vamos a configurarlo para que tome el SSID adecuado con la seguridad respectiva y se enganche al Wireless Router y tenga acceso a la red, para esto realizarnos la siguiente configuración como se muestra en la siguiente figura, que básicamente debe ser igual a los parámetros configurados en el Wireless Router.

 

Hasta el momento hemos revisado lo que respecta a la configuración Wireless LAN, ahora veremos la parte de “Internet”, que es la interfaz del Wireless Router que se conecta al resto de la red para alcanzar todos los servicios de la red.

 

Como configuramos anteriormente, el Internet Setup del Wireless Router, tiene varias opciones de conexión, de cómo configurar su interfaz “Internet,” con una dirección IP estática, dinámica, Wireless AP, y Wireless Media Bridge, como se muestra en la siguiente figura:

 

 

En este LAB escogimos que la interfaz “Internet” tomara una dirección del DHCP, y que en este caso el DHCP Server es el Router-ISP.

Por ende, configuraremos este router para que nos entregue una dirección IP a la interfaz “Internet” del Wireless Router, como sigue:

 

Configuración del Router-ISP

 

ip dhcp excluded-address 172.16.0.3

ip dhcp excluded-address 172.16.0.100

ip dhcp excluded-address 172.16.0.1

!

ip dhcp pool POOL-GERENCIA

network 172.16.0.0 255.255.255.0

default-router 172.16.0.1

dns-server 172.16.0.100

 

!

interface GigabitEthernet0/0

ip address 172.16.0.1 255.255.255.0

!

interface GigabitEthernet0/1

ip address 200.200.200.1 255.255.255.0

 

El comando “ip dhcp excluded-address”, nos ayuda a excluir direcciones IP desde el pool de direcciones que tenemos disponibles, en este lab, por ejemplo, excluimos las direcciones del router, del switch y del servidor de DNS.

El comando “ip dhcp pool” crea el pool de direcciones IP, disponibles para ser asignados a quien requiera una dirección IP.

También vemos las direcciones ip asignadas a las interfaces de Giga del Router-ISP

 

Configuración de Servicios

 

En cuanto a los servicios del LAB, se han configurado DNS y WEB, como sigue:

 

DNS Server

 

Web Server

 

Pruebas de conectividad y servicios

 

Laptop0

Toma de dirección IP por DHCP (Wireless Router)

En este caso el Laptop0 toma la primera dirección IP del pool de direcciones IP disponibles del DHCP del Wireless Router, toma la máscara, el Gateway y la dirección del servidor de DNS

 

Prueba de conectividad hasta el Gateway, Router-ISP y Web Server

Pruebas de servicio WEB

 

 

Pack CCNA 200-301 Oferta

Pack Cisco CCNA 200-301 AQUí

Configuración de NAT estática y NAT dinámica

Configuración de NAT estática y NAT dinámicaManuel Sepúlveda

Configuración de NAT estática y NAT dinámica eclassvirtual

Configuración de Router1 – NAT dinámico

 

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Serial0/0/0

ip address 200.123.234.25 255.255.255.240

ip nat outside

!

ip nat pool IP-Publicas 200.123.234.17 200.123.234.24 netmask 255.255.255.240

ip nat inside source list 1 pool IP-Publicas

!

access-list 1 permit 192.168.1.0 0.0.0.255

 

 

Configuración de Router2 – NAT estático

 

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

ip nat inside

!

interface Serial0/0/0

ip address 200.123.234.26 255.255.255.240

ip nat outside

!

ip nat inside source static 10.10.10.100 200.123.234.30

 

Pruebas de NAT

 

Ping desde PC0 a IP NAT de Web Server (200.123.234.30)

 

C:\>ping 200.123.234.30

 

Pinging 200.123.234.30 with 32 bytes of data:

 

Reply from 200.123.234.30: bytes=32 time=2ms TTL=126

Reply from 200.123.234.30: bytes=32 time=1ms TTL=126

Reply from 200.123.234.30: bytes=32 time=2ms TTL=126

Reply from 200.123.234.30: bytes=32 time=1ms TTL=126

 

Ping statistics for 200.123.234.30:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 2ms, Average = 1ms

 

Router1#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp 200.123.234.17:46 192.168.1.100:46 200.123.234.30:46 200.123.234.30:46

icmp 200.123.234.17:47 192.168.1.100:47 200.123.234.30:47 200.123.234.30:47

icmp 200.123.234.17:48 192.168.1.100:48 200.123.234.30:48 200.123.234.30:48

icmp 200.123.234.17:49 192.168.1.100:49 200.123.234.30:49 200.123.234.30:49

 

 

Prueba de servicio WEB desde PC0

Prueba NAT WEB eclassvirtual

 

Router1#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

tcp 200.123.234.17:1032192.168.1.100:1032 200.123.234.30:80 200.123.234.30:80

 

 

Router2#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

— 200.123.234.30 10.10.10.100 — —

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1025200.123.234.17:1025

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1026200.123.234.17:1026

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1027200.123.234.17:1027

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1028200.123.234.17:1028

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1029200.123.234.17:1029

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1030200.123.234.17:1030

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1031200.123.234.17:1031

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1032200.123.234.17:1032

Descarga este LAB gratis desde 

LAB NAT ESTATICO Y DINAMICO

Matemáticas digitales para el direccionamiento IP

Matemáticas digitales para el direccionamiento IPManuel Sepúlveda

Introducción

 

Las matemáticas digitales son necesarias para interpretar adecuadamente la notación utilizada en las direcciones IP

 

Notación binaria

 

Utiliza únicamente 2 valores: 1 y 0

Por ejemplo: 10010111

Esta notación binaria es necesaria para realizar varios procedimientos lógicos que se aplican en la asignación y simplificación de direcciones.

 

Notación decimal

 

Sistema de 10 símbolos con valores: 0,1,2,3,4,5,6,7,8,9

 

Notación hexadecimal

 

Elaborado en base a 16 valores posibles: 0,1,2,3,4,5,6,7,8,9,a,b,c,d,e,f

La correspondencia entre la notación hexadecimal y el decimal es la siguiente:

 

Conversión de notación binaria a notación decimal

 

Para esta conversión es necesario considerar que cada posición binaria representa una potencia de 2, esto es, por ejemplo:

 

11111111 = 27 + 26 + 25 + 24 + 23 + 22 + 21 + 20 = 128 + 64 + 32 + 16 + 8 + 4 + 2 + 1 = 255

 

10101010 = 27 + 0 + 25 + 0 + 23 + 0 + 21 + 0 = 128 + 0 + 32 + 0 + 8 + 0 + 2 + 0 = 170

 

Por que una dirección IP expresada en binario también se puede expresar en decimal:

  1. 10101000. 00000000.00000001 = 192.168.0.1

 

Conversión de notación decimal a notación binario

 

En este caso se usa el algoritmo llamado “Dividir por 2”, como sigue utilizando el número decimal 192:

 

Como se puede apreciar, el número binario se toma desde el último residuo hasta el primero.

 

Haciendo el ejemplo con el decimal 172:

Conversión entre diferentes notaciones

 

Hexadecimal                      a0

Decimal                               10      0

Binario                                 1010 0000

 

Hexadecimal                     ab

Decimal                               10     11

Binario                                 1010 1011

 

Practíca y realiza las siguientes conversiones

 

De decimal a binario

 

  • 255 =
  • 10 =
  • 255.255.255.0 =

 

De binario a decimal

  • 11100000 =
  • 00001111 =
  • 10000001 =

 

De Hexadecimal a binario

  • 2f =
  • 33 =
  • 1e =