Seleccionar página
Configuración de Servidores DNS y DHCP en Packet Tracer

Configuración de Servidores DNS y DHCP en Packet Tracer

Que es un DHCP Server:

 

Un DHCP Server, permite a un host obtener una dirección IP de forma dinámica cuando se conecta a la red. El host contacta a un servidor DHCP para obtener una dirección IP, el servidor DHCP elige una dirección IP de un rango de direcciones que tiene en un grupo (también llamado pool de direcciones) y se la asigna al host por un periodo de tiempo determinado, como se muestra en la siguiente figura:

Servidor DHCP

Servidor DHCP

 

 

Cuando un dispositivo configurado con DHCP se conecta a la red, el cliente emite un

Paquete DHCPDISCOVER para identificar cualquier servidor DHCP disponible en la red.

 

Entonces un servidor DHCP responde con un DHCPOFFER, que es un mensaje de oferta de asignamiento con una dirección IP asignada, máscara de subred, servidor DNS e información de la puerta de enlace predeterminada, así como la duración del asignamiento.

 

El cliente puede recibir múltiples paquetes DHCPOFFER si la red local tiene más de uno

Servidor DHCPv4. El cliente elige la primera oferta y transmite un paquete DHCPREQUEST que identifica el servidor explícito y la oferta de asignamiento que está aceptando.

 

Suponiendo que la dirección IP sigue siendo válida, el servidor elegido devuelve un mensaje de DHCPACK (confirmación), finalizando el contrato de asignamiento (arrendamiento).

 

DHCP Server en Cisco Packet Tracer

 

En Cisco Packet Tracer (CPT) podemos usar servidores que emulan el servicio de DCHP y se puede configurar de la siguiente manera:

Servidor DHCP Cisco Packet Tracer

Servidor DHCP Cisco Packet Tracer

 

  1. En “Service” puedes encender o apagar el servicio DHCP
  2. En este apartado puedes configurar:
    1. Nombre del Pool o Grupo
    2. Puerta de enlace
    3. La dirección IP del Servidor DNS
    4. La dirección IP de inicio del pool
    5. La máscara de subred
    6. El número máximo de direcciones IP que contendrá el pool
    7. La dirección IP del Servidor TFTP
    8. La dirección IP del Wireless Lan Controller WLC
  3. Nombre y configuración de cada pool o grupo configurado para las distintas subredes

 

 

Configuración de un router Cisco como un DHCP Server

 

Un router Cisco que ejecute el software Cisco IOS puede configurarse para actuar como un servidor DHCPv4.

 

El servidor Cisco IOS DHCP asigna y administra direcciones IPv4 desde el pool de direcciones especificas que está dentro del router, para los clientes DHCP

 

Pasos para configurar un router como un DHCP Server:

 

  1. Use el comando “ip dhcp excluded-address low-address [high-address]” para identificar una dirección o rango de direcciones para excluir del grupo DHCP. Por ejemplo:

 

R3(config)# ip dhcp excluded-address 192.168.40.1 192.168.40.100

 

  1. Cree el grupo DHCP utilizando el comando “ip dhcp pool pool-name”, que

te coloca en modo de configuración DHCP:

 

R3(config)# ip dhcp pool RED-40

R3(dhcp-config)#

 

  1. Configuramos los parámetros de direccionamiento IP que necesitamos asignar automáticamente, por ejemplo:

 

ip dhcp pool RED-40

network 192.168.40.0 255.255.255.0

 default-router 192.168.40.1

 dns-server 192.168.20.100

 

Comandos de verificación de operación de DHCP

 

R3#show ip dhcp binding

IP address       Client-ID/              Lease expiration        Type

Hardware address

192.168.40.101   00D0.D3EA.CEC0           —                     Automatic

 

 

Configuración de un router para retransmitir solicitudes DHCP

 

En una red compleja, los servidores DHCP generalmente están contenidos en una granja de servidores. Por lo tanto, los clientes generalmente no están en la misma subred que el servidor DHCP.

 

Para garantizar que los mensajes DHCPDISCOVER emitidos se envíen al servidor DHCP remoto, usamos el comando ip helper-address, por ejemplo, en la siguiente imagen, se configuran los segmentos de redes del router con el comnando ip helper-address, para que los clientes de estos segmentos puedan obtener la configuración IP necesaria para que se conecten de forma satisfactoria a la red

Configuracion DHCP y DNS Server - IP Helper-Address

Configuracion DHCP y DNS Server – IP Helper-Address

 

interface GigabitEthernet0/1

ip address 192.168.10.1 255.255.255.0

ip helper-address 192.168.20.102

duplex auto

speed auto

!

interface GigabitEthernet0/2

ip address 192.168.30.1 255.255.255.0

 ip helper-address 192.168.20.102

duplex auto

speed auto

 

El paquetes DHCPDISCOVER es un broadcast que lo recibe el router y que es convertido en un paquete Unicast dirigido hacia la dirección IP del DHCP Server, todo esto por medio del comando “ip helper-address”

 

Que es un DNS Server:

 

DNS es un sistema distribuido de servidores que resuelve nombres de dominio en direcciones IP. El nombre de dominio es parte del identificador uniforme de recursos (URI)

Estructura URI:

URI DNS Server

URI DNS Server

 

 

Cuando se escribe un nuevo URI en el navegador, la computadora usa DNS para enviar una solicitud para que resuelva el URI en una dirección IP. Por ejemplo, un Servidor DNS resuelve la URI www.eclassvirtual.com en la dirección IP 35.214.133.151.

 

El servidor DNS almacena diferentes tipos de registros de recursos utilizados para resolver nombres. Estos registros contienen el nombre, la dirección y el tipo de registro. Algunos de estos tipos de registros son los siguientes:

 

  • A: Una dirección IPv4 de un dispositivo final
  • NS: Un servidor de nombres autorizado
  • AAAA: Una dirección IPv6 de un dispositivo final
  • MX: Un registro de intercambio de correo

 

Cuando un cliente realiza una consulta, el proceso DNS del servidor primero mira sus propios registros para resolver el nombre. Si no puede resolver el nombre usando sus registros almacenados, contacta a otros servidores para resolver el nombre.

 

Los servidores raíz DNS administran los sufijos de dominio superior, como estos:

 

  • .com: Negocios comerciales
  • .edu: Organizaciones educativas
  • .gov: Organizaciones gubernamentales
  • .mil: Organizaciones militares
  • .net: Organizaciones de redes, como los ISP
  • .org: Organizaciones no comerciales

 

También existen servidores DNS de nivel superior para cada código de país, como .ca (Canadá), .de (Alemania), .ru (Rusia) y .cn (China).

 

 

DNS Server en Cisco Packet Tracer

 

En CPT también podemos simular servidores DNS, como se muestra en la siguiente figura:

DNS Server Cisco Packet Tracer

DNS Server Cisco Packet Tracer

 

  1. Podemos subir o bajar el servicio de DNS
  2. Agregamos un nombre y su tipo. Puede ser A Record, CNAME, SOA y NS Record
  3. Agregamos su dirección IP
  4. Y nos muetra la tabla de registros DNS

 

Pack Cisco CCNA 200-301, con oferta de descuento aquí

Configuración de qos en packet tracer para el CCNA 200-301

Configuración de qos en packet tracer para el CCNA 200-301

La Calidad de Servicio (QoS) para el CCNA:

Un switch en su modo de funcionamiento normal, envía todo el tráfico desde el origen al destino, sin importar que tipo de trafico es, solo recibe una trama Ethernet, mira la dirección MAC de destino y direcciona la trama al destinatario. Lo mismo ocurre en un router, éste recibe un paquete IP, mira por el destino en la tabla de routing y direcciona el paquete hacia el destinatario.

Este tipo de reenvío se llama “best effort” o mejor esfuerzo o FIFO (First in First Out), es decir el primero en entrar es el primero en salir.

 

QoS entre otras cosas permite:

  • Controlar la congestión cuando la demanda del ancho de banda (BW) es mayor al BW disponible
  • Priorizar servicios según su naturaleza
  • Asignar distintos tipos de BW de acuerdo a perfiles de tráfico
  • QoS es parte de la demoninada redes convergentes, convergencia de voz sobre IP, video y datos simultáneamente.

El grupo de trabajo Internet Engineering Task Force (IETF), define dos tipos de calidad de servicio:

  • IntServ –> Servicios Integrados
  • DiffServ –> Servicios diferenciados, DiffServ es el modo más ampliamente usado en las redes actuales
  • IntServ:
    • Provee la garantía más alta de QoS
    • Intensivo uso de recursos
    • Limitada escalabilidad
    • USA RSVP (Resource Reservation Protocol) para establecer un circuito virtual de QoS de extremo a extremo
  • DiffServ:
    • Alta flexibilidad y escalabilidad en la implementación de QoS
    • Los dispositivos de red reconocen clases de trafico
    • Provee diferentes niveles de QoS a diferentes clases
    • Se define un dominio de QoS
    • La política de QoS se debe aplicar en cada uno de los saltos de la red, también llamado Per Hop Behaviour, que en español sería como «Comportamiento por cada salto»

Dominio QoS Diffserv

 

Conceptos importantes que se deben tener en cuenta en el uso de QoS:

  • Control de la congestión: Una interfaz experimenta congestión cuando tiene más tráfico del que puede gestionar. El resultado de la congestión es el retaso (latencia) que impactan directamente a servicios con tráfico interactivo y en tiempo real (ej. Voz sobre IP)
  • Perdida de paquetes: En periodos de alta congestión, los dispositivos de red optan por descartar (drop) paquetes IP, por lo que sin QoS el descarte de paquetes es la misma para tráfico sensible como para tráfico no sensible.
  • Perfiles de tráfico:
    • Voz sobre IP, convierte las señales de voz en paquetes de datos comprimidos que son transportados por medio de redes de datosTelefono IP Cisco
      • Tráfico predecible y relativamente estable
      • Bajo consumo de recursos
      • Son muy sensibles a la latencia o delay, menos de 150ms
      • Tráfico muy sensible a las pérdidas o drop, menos del 1%
      • No tolera retransmisiones
      • Usa UDP (User datagram protocol)
      • El jitter o fluctuación del retardo debe ser menor a 30ms
      • Ancho de banda (BW) entre 30Kpbs a 128Kbps, depende del codificador en uso

 

  • Video sobre IP, es una solución de transporte de audio y video sobre redes IP Video sobre IP QoS
    • Genera trafico impredecible y en ráfagas en ciertos momentos
    • Sensible a pérdidas de 0,1 a 1% máximo
    • Sensible a latencia hasta 400 ms
    • BW entre 384Kbps a 30Mbps
    • Jitter no mayor a 50ms

 

  • Tráfico de datosTrafico de datos QoS
    • Tráfico impredecible y que facilmente genera ráfagas de tráfico
    • Generalmente insensible a perdidas y latencias
    • Retransmisión de paquetes por medio de TCP
    • Puede fácilmente consumir el ancho de banda de un enlace

 

Políticas de control de QoS – Encolamiento o Queuing 

Encolamiento o Queuing, es una herramienta de control de congestión que permite priorizar, administrar buffers y reordenar paquetes antes de ser transmitido a un destino.

Existen distintos tipos de encolamiento entre los más destacados se encuentran:

  • FIFO: First-in, first-out, el primero en llegar es el primero en salir,  es el método de encolamiento más sencillo, en el encolamiento FIFO todos los paquetes son tratados de igual manera y son puestos dentro de una única cola, y son entregados en el mismo orden en el que son colocados dentro de la cola, es decir el primero paquete que ingresa es el primero que sale. Su desventaja es que maneja una cantidad de flujo de paquetes limitada, es decir cuándo la cola está llena de paquetes, éste los descarta. En esta configuración los paquetes no son reordenados y el retardo máximo viene determinado por el tamaño máximo de la cola.  

Encolamiento FIFO QOS

  • WFQ: Weighted Fair Queueing, encolamiento controlado basado en pesos, este método provee una asignación de ancho de banda para todo el tráfico de la red, esta asignación de ancho de banda es la que determina el orden de como serán entregados los paquetes, y es hecha usando filtros disponibles en el datagrama IP, como las direcciones de origen y destino, o el campo TOS. WFQ crea una cola distinta para cada tipo de tráfico asignándole a cada uno, valores de profundidad para las colas, las cuales pasan a través de un servidor round robín siguiendo un orden secuencial circular. Como cada flujo tiene una cola asignada si se presentan demasiadas tramas de datos solo se vera afectado el rendimiento de la cola para cada clase especifica.

WFQ QoS Calidad de Servicio

  • CBWFQ: Class based weigthed fair queueing, encolamiento controlado basado en pesos basado en clases, Extiende las características del encolamiento tipo WFQ, ya que le otorga a los usuarios la habilidad de crear diferentes clases de trafico, estas son definidas usando el campo DSCP del datagrama IP, configurando listas de acceso o usando las interfaces de entrada como herramientas para configurar el encolamiento de paquetes. En este tipo de encolamiento, una cola es reservada para cada clase, y el tráfico correspondiente a cada una de ellas va directamente a la cola asignada para esa clase. Para caracterizar las clases, se debe especificar el límite de la cola para esa clase, así como el ancho de banda, el peso, y el número máximo de paquetes que soportara. El ancho de banda que se le asigne será el ancho de banda que tendrá esa clase durante la congestión.

CBWFQ QoS Calidad de Servicio

 

  • LLQ: Encolamiento de baja latencia Low Latency queueing, es una mezcla entre el tipo de encolamiento de prioridad y el anteriormente explicado CBWFQ, es el método de encolamiento característico de las aplicaciones de telefonía IP y VoIP, LLQ esta basado en el uso de colas de prioridad personalizadas, las cuales están basadas en clases de trafico pre configuradas por el administrador de los servicios de red, estas clases de trafico en conjunto con una cola de prioridad, la cual tiene la mayor preferencia sobre las demás colas correspondiente a los diferentes flujos de datos. Si hay presencia de tráfico en la cola de prioridad, ésta es atendida antes que las demás colas de prioridad personalizadas, si la cola de prioridad absoluta no esta encolando paquetes, las demás colas son atendidas según su prioridad asignada.

LLQ QoS Calidad de Servicio

 

Proceso General de QoS y secuencia de operación sobre el flujo de paquetes

Calidad de Servicio QoS General

Marcado de tráfico

Antes de aplicar QoS, un paquete debe ser marcado para después asignarle una clase determinada según el tipo de tráfico

Formas de marcado:

Marcado de tráfico Calidad de Servicio QoS

 

Marcado de tráfico en capa 2

  • Usa el campo de prioridad 802.1p también llamado Class of Service (CoS)
  • Diferentes tipos de tráfico son asignados a diferentes valores de CoS
  • CoS 6 y 7 son reservados para uso de la red

QoS Marcado de trafico en capa 2

Marcado de tráfico en capa 3

  • IP Precedence está obsoleto
  • Uso de 6 bits para DSCP

Marcado capa 3 QoS Paquete IP

Mapeo de marcado de capa 2 a capa 3

En la siguiente tabla se muestra los distintos tipos de mapeos dependiendo del marcado:

Tabla QoS CoS DSCP Calidad de Servicio

Ejemplo de mapeo de marcado de capa 2 a capa 3

  • Para tráfico voz: CoS = 5 –> DSCP = EF = 101110 (6 primeros bit) = 0x2e (Hex) = 46 (Decimal)
  • Para tráfico misión crítica: Cos = 3 –> DSCP = AF31 = 011010 (6 primeros bit) = 0x1a (Hex) = 26 (Decimal)
  • Para tráfico builk data: CoS = 1 –> DSCP = AF11 = 001010 (6 primeros bit) = 0x0a (HeX) = 10 (Decimal)

Topología Calidad de Servicio QoS en Cisco Packet Tracer

Topología Calidad de Servicio QoS Cisco Packet Tracer

Configuración Router0

class-map match-all voice

match protocol rtp

class-map match-all http

match protocol http

class-map match-all icmp

match protocol icmp

!

policy-map marcado

class voice

  priority 100

  set ip dscp ef

class http

  bandwidth 50

  set ip dscp af31

class icmp

  bandwidth 25

  set ip dscp af11

!

interface GigabitEthernet0/0/0

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0

bandwidth 250

ip address 10.1.2.1 255.255.255.0

service-policy output marcado

clock rate 250000

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

 

Configuración Router1 

class-map match-all voice

match ip dscp ef

class-map match-all http

match ip dscp af31

class-map match-all icmp

match ip dscp af11

!

policy-map remarcado

class voice

  set precedence 5

class http

  set precedence 3

class icmp

  set precedence 0

!

interface GigabitEthernet0/0/1

ip address 10.1.3.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/2/0

ip address 10.1.2.2 255.255.255.0

service-policy input remarcado

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

Revisión de Marcado QoS en Cisco Packet Tracer

Revisaremos ahora como se ven los paquetes IP con el marcado DSCP, cuando realizamos un tráfico http

 

La siguiente imagen, muestra la PDU de entrada en el Router0 donde se ve que el DSCP es 0x00

PDU Entrada Router0 QoS

 

La siguiente imagen se ve como QoS marca el paquete en la PDU de salida con un DSCP de 0x1a

PDU Salida Router0 QoS

 

La siguiente imagen muestra como en Router1 llega el paquete marcado en la PDU de entrada con el valor enviado por el Router0 que es 0x1a

PDU Entrada Router1 QoS

 

En la siguiente imagen se muestra como la PDU es remarcada por el valor de 0x18

PDU Salida Router1 QoS

Laboratorio en Cisco Packet Tracer de Calidad de Servicio (QoS) lo puedes ver aquí 

Próximamente este post estará en Video, así que suscríbete en mi canal de youtube aquí

Configuración de NAT estática y NAT dinámica

Configuración de NAT estática y NAT dinámica

Configuración de NAT estática y NAT dinámica eclassvirtual

Configuración de Router1 – NAT dinámico

 

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Serial0/0/0

ip address 200.123.234.25 255.255.255.240

ip nat outside

!

ip nat pool IP-Publicas 200.123.234.17 200.123.234.24 netmask 255.255.255.240

ip nat inside source list 1 pool IP-Publicas

!

access-list 1 permit 192.168.1.0 0.0.0.255

 

 

Configuración de Router2 – NAT estático

 

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

ip nat inside

!

interface Serial0/0/0

ip address 200.123.234.26 255.255.255.240

ip nat outside

!

ip nat inside source static 10.10.10.100 200.123.234.30

 

Pruebas de NAT

 

Ping desde PC0 a IP NAT de Web Server (200.123.234.30)

 

C:\>ping 200.123.234.30

 

Pinging 200.123.234.30 with 32 bytes of data:

 

Reply from 200.123.234.30: bytes=32 time=2ms TTL=126

Reply from 200.123.234.30: bytes=32 time=1ms TTL=126

Reply from 200.123.234.30: bytes=32 time=2ms TTL=126

Reply from 200.123.234.30: bytes=32 time=1ms TTL=126

 

Ping statistics for 200.123.234.30:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 2ms, Average = 1ms

 

Router1#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp 200.123.234.17:46 192.168.1.100:46 200.123.234.30:46 200.123.234.30:46

icmp 200.123.234.17:47 192.168.1.100:47 200.123.234.30:47 200.123.234.30:47

icmp 200.123.234.17:48 192.168.1.100:48 200.123.234.30:48 200.123.234.30:48

icmp 200.123.234.17:49 192.168.1.100:49 200.123.234.30:49 200.123.234.30:49

 

 

Prueba de servicio WEB desde PC0

Prueba NAT WEB eclassvirtual

 

Router1#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

tcp 200.123.234.17:1032192.168.1.100:1032 200.123.234.30:80 200.123.234.30:80

 

 

Router2#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

— 200.123.234.30 10.10.10.100 — —

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1025200.123.234.17:1025

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1026200.123.234.17:1026

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1027200.123.234.17:1027

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1028200.123.234.17:1028

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1029200.123.234.17:1029

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1030200.123.234.17:1030

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1031200.123.234.17:1031

tcp 200.123.234.30:80 10.10.10.100:80 200.123.234.17:1032200.123.234.17:1032

Descarga este LAB gratis desde 

LAB NAT ESTATICO Y DINAMICO