Seleccionar página
Laboratorio CCNA 1 – Como asegurar el acceso Cisco 

Laboratorio CCNA 1 – Como asegurar el acceso Cisco 

Como asegurar el acceso Cisco

 

Te muestro como puedes asegurar el acceso Cisco por consola: 

Switch> enable 

Switch# configure terminal 

Switch(config)# line console 0 

Switch(config-line)# login 

Switch(config-line)# password cisco 

Switch(config-line)# exec-timeout 10 0 

Switch(config-line)# logging synchronous 

Switch(config-line)# exit 

 

Asegurar el acceso Cisco por terminal virtual: 

 Switch(config)# line vty 0 4 

Switch(config-line)# login 

Switch(config-line)# password cisco 

Switch(config-line)# exec-timeout 10 0 

Switch(config-line)# exit 

Switch(config)#  

 

Asegurar el acceso Cisco en modo privilegiado: 

Switch# configure terminal 

Switch(config)# enable secret cisco123 

Switch(config)# exit 

Switch# 

 

Verificar que la clave se encuentra cifrada con el siguiente comando: 

Switch# show run 

Mirar la línea 👇

 enable secret 5 $1ejdjfj5.dmjfjedjr484dhbd 




  

 

Asegurar el acceso Cisco por el protocolo SSH 

Switch# configure terminal 

Switch(config)# hostname SW01 

SW01(config)# username admin secret cisco 

SW01(config)# ip domain-name eclassvirtual.com 

SW01(config)# crypto key generate rsa  

SW01(config)# ip ssh version 2 

SW01(config)# line vty 0 4 

SW01(config-login)# login local 

SW01(config-login)# transport input ssh 

SW01(config-login)# exit 

SW01(config)# exit 

SW01# show ip ssh 

 



Interfaces de programación de aplicaciones (API) para el CCNA

Interfaces de programación de aplicaciones (API) para el CCNA

Interfaces de programación de aplicaciones (API) para el CCNA

 

En este artículo aprenderás sobre las Interfaces de programación de aplicaciones (API) para el CCNA

En las redes tradicionales las opciones para conectarnos a los dispositivos de la red son por medio de protocolos como Telnet, SSH y SNMP

 

En la actualidad los fabricantes de dispositivos han implementado API para facilitar la operación de los administradores y lograr mayor flexibilidad para la operación.

 

Las API requieren de protocolos de transporte como SSH, HTTPS o más innovadores

 

Un red SDN (Software Defined Networking) entregan un mecanismo centralizado de control alojado en el controlador sobre el cual se implementan las APIs para comunicarse con las capas de infraestructura y de aplicación

 

Interfaces de programación de aplicaciones (API) para el CCNA

 

 

Por una parte tenemos las API Northbound, que son las interfaces que ofrecen los servicios a la capa de aplicación, estas interfaces permiten que las aplicaciones administren y/o controlen la red.

 

Estas aplicaciones van desde la virtualización de redes y el aprovisionamiento dinámico de redes virtuales hasta un monitoreo más gradual de un firewall.

 

Actualmente, se suele utilizar API REST para la comunicación entre el controlador y las aplicaciones.

 

La comunicación del controlador con la capa de infraestructura se define como API Southbound. Los protocolos que se utilizan entre el controlador  y los dispositivos de infraestructura son:

 

  • Openflow: API estándar de la industria, definida por la ONF. Permite el acceso directo y la manipulación del plano de reenvío de tráfico de los dispositivos de la red tanto físicos como virtuales
  • NETCONF: Protocolo de gestión de red estandarizado por la IETF. Proporciona mecanismos para instalar, manipular y eliminar la configuración de dispositivos de red mediante mecanismos RPC
  • RESTCONF: Mecanismo que agrega una API REST a NETCONF
  • OpFlex: Protocolo abierto que proporciona un sistema de control distribuido que se basa en un modelo de información de política declarativa.
  • REST: Permiten a los controladores monitorear y administrar la infraestructura a través de los HTTP/HTTPS, utilizando las acciones HTTP como GET, POST, PUT, DELETE,etc. Que utilizan los navegadores web para recuperar páginas web
  • SNMP: Se utiliza para comunicar información de gestión entre las estaciones de gestión de la red y los agentes en los dispositivos de la red.
  • Otros protocolos: Como NX-API para la familia de switches de Data Center de Cisco Nexus

 

 

Como crear Vlan y enlaces troncales Cisco

Como crear Vlan y enlaces troncales Cisco

En este articulo vamos a aprender a como crear Vlan y enlaces troncales Cisco por medio de una red compuesta por un switch Multilayer como lo es el modelo WS-C3560-24PS, un equipo con capacidades de trabajar tanto en la capa 2 como en la capa 3 del modelo OSI.

 

Además, vamos a agregar dos switch de capas 2 como lo son el modelo WS-C2960-24TT-L, más 4 PC con direcciones IP fijas para completar una red tradicional.

Creacion de VLAN y Enlaces Troncales

 

En nuestro ejemplo:

  • Se han configurado la VLAN 10 y 20 tanto en los switches de capa 2 como el switch Multilayer
  • Cada VLAN se ha mapeado a una subred diferente, la VLAN 10 a la 192.168.10.0/24 y la VLAN 20 a la 192.168.20.0/24
  • Los switches de capa 2 se conectan al switch Multilayer utilizando un enlace troncal IEEE 802.1Q a través del cual se transportan todas las VLANs permitidas, en este ejemplo se permiten solo las VLAN 10 y 20.

 

 

A continuación, les comparto las configuraciones de la red:

 

! Asigna un nombre identificatorio al switch Multilayer

hostname Multilayer

!

! Activa el enrutamiento IP

ip routing

!

! Creación y configuración de VLAN

! Esto no aparece en el archivo de configuración

vlan 10

vlan 20

!

! Configuración del enlace troncal

interface FastEthernet0/1

description puerto troncal

switchport trunk allowed vlan 10,20

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

description puerto troncal

switchport trunk allowed vlan 10,20

switchport trunk encapsulation dot1q

switchport mode trunk

!

! Creación de SVI para la VLAN 10

interface Vlan10

description Gateway de la VLAN 10

mac-address 00d0.d367.aa01

ip address 192.168.10.1 255.255.255.0

!

! Creación de SVI para la VLAN 20

interface Vlan20

description Gateway de la VLAN 20

mac-address 00d0.d367.aa02

ip address 192.168.20.1 255.255.255.0

 

*************************************************

! Asigna un nombre identificatorio al switch capa 2

hostname Switch1

!

! Creación y configuración de VLAN! Esto no aparece en el archivo de configuración

vlan 10

vlan 20

!

! Configuración de las interfaces de acceso de la VLAN 10

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

!

! Configuración de las interfaces de acceso de la VLAN 20

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

!

! Configuración de puerto troncal

interface FastEthernet0/24

description puerto troncal

switchport trunk allowed vlan 10,20

switchport mode trunk

 




***********************************************

 

! Asigna un nombre identificatorio al switch capa 2

hostname Switch2

!

! Creación y configuración de VLAN

! Esto no aparece en el archivo de configuración

vlan 10

vlan 20

!

! Configuración de las interfaces de acceso de la VLAN 10

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

!

! Configuración de las interfaces de acceso de la VLAN 20

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

!

! Configuración de puerto troncal

interface FastEthernet0/24

description puerto troncal

switchport trunk allowed vlan 10,20

switchport mode trunk

 

 

Algunas notas para el switch Multilayer:

 

  • Los switches de capa 3 no operan por defecto en la capa de red por lo que se debe activar el enrutamiento IP por medio del comando “ip routung”
  • Los puertos de los switches operan por defecto en la capa 2, para habilitar la capa 3 en cada puerto se debe deshabilitar el Switching por medio del comando “no switchport”, de esta manera se podrá configurar una dirección ip en el puerto específico
  • Para que un switch Multilayer actúe como Gateway de las terminales que forman parte del domino de broadcast definido por una VLAN, se deben configurar SVI (Switch Virtual Interface). Una SVI es una interfaz virtual que no esta vinculada a un puerto físico del dispositivo, que opera como una interfaz completa de salida de una Vlan

 

Algunas notas para los switches de capa 2:

 

  • Los comandos de configuración de Vlans no se guardan en el archivo de configuración del switch
  • Si quieres configurar múltiples puertos con los mismos comandos, puedes utilizar el comando “interface range”, por ejemplo “inteface range f0/1-2”

Configuración de Router Inalámbrico en Cisco Packet Tracer

Configuración de Router Inalámbrico en Cisco Packet Tracer

En este video veremos como configurar un router inalámbrico Cisco en Packet Tracer.

Configuraremos el Wireless Router, su dirección IP, y el servicio de DHCP para que entregue direcciones IP de forma automática a los clientes inalámbricos que tengan configurado el SSID o Service Set Identifier que es el nombre que damos a una red Wi-Fi determinada. A nivel técnico, actúa como un código que permite identificar la red inalámbrica que representa.

 

Configuracion Wireless Router Cisco

 

Para la configuración del SSID lo podemos hacer como se ve en la siguirnte imagen

 

Configuracion SSID Wireless Router Cisco

 

Luego de configurar el SSID, vamos a comfigurar el tipo de seguridad inalámbrica, que para este caso será WPA2 Personal con PSK que son las siglas de Pre Shared Key (clave compartida previamente), es decir, la seguridad de la red WiFi se basa en un secreto compartido (la contraseña de la red WiFi), que conocen sus usuarios y el punto de acceso, en este caso el Wireless Router es el Access Point o punto de acceso.

Para terminar con la configuración de los parámetros de seguridad inalámbricas usaremos el cifrado Advanced Encryption Standard (AES) que es uno de los algoritmos de cifrado más utilizados y seguros actualmente disponibles.

Configuracion Seguridad Wireless Router WPA2 AES

Por el lado del cliente inalámbrico, también tenemos que configurar los mismos parametros, es decir, misma red SSID, misma Seguridad inalámbrica

Configuracion PC Inalambrico WIFI SSID WPA2 PSK AES

Para más detalle miren el video, esta todo explicado el paso a paso, nos vemos, un abrazo

 

Frecuencias y canales en redes LAN inalámbricas WIFI

Frecuencias y canales en redes LAN inalámbricas WIFI

Frecuencias y Canales en Redes LAN Inalámbricas WIFI

 

Las redes WIFI se basan en el estándar IEEE 802.11 y operan en las bandas de 2,4 GHZ y 5 GHZ

 

Hay que tener en cuenta que estas frecuencias no son de uso exclusivo por lo que se debe considerar la presencia de señales ajenas al funcionamiento de nuestra red, como por ejemplo la banda de 2,4 GHz es usada también por transmisiones de video, Bluetooth, hornos microondas y teléfonos inalámbricos, por lo que siempre debemos considerar ola interferencia de nuestras redes inalámbricas sobre todo en el rango de 2,4 GHz.

 

La familia de estándares IEEE 802.11 es la siguiente:

 

Frecuencias y canales WIFI

 

Cada AP opera en un canal, por lo que el diseño debe considerar que los APs vecinos no utilicen el mismo canal para alcanzar una operación óptima, esto hace necesario contar con múltiples canales que no se superpongan.

 

La banda de 2,4 GHz está disponible prácticamente en todo el mundo, tiene un ancho de canal de 22 MHz con una separación de 5 MHz entre sí.

 

En Estados Unidos tienen 11 canales disponibles, en Europa 13 y en Japón 14 canales

 

En un esquema de 11 o 13 canales, solo hay tres canales que no se superponen y que son el 1, 6 y 11

 

Frecuencias y canales WIFI

 

 

Si intentas usar el canal 1 y 2 dará lugar a problemas de interferencia, en Japón se pueden usar cuatro canales y que son el 1, 6, 11 y 14

 

802.11n permite utilizar canales de 40 MHz para 2,4 GHz, sin embargo, este tipo de implementación solo es factible en instalaciones hogareñas. Además, el uso de canales de 40 MHz en la banda de 2,4 GHz reduce la cantidad de canales no superpuestos.

 

En la banda de 5 GHz suele dividirse en varias secciones: cuatro bandas UNII y una banda ISM. Los canales que componen cada una de estas secciones están espaciada a intervalos de 20 MHz y se consideran no interferentes.

 

Frecuencias y canales WIFI

 

Considerando la cantidad de canales no superpuestos disponibles en esta banda, es donde mejor se puede fusionar dos o más canales adyacentes para poder operar con canales más anchos de 40, 80 0 160 MHz, lo que en la práctica se traduce en conexiones de mayor capacidad de transmisión ya que se multiplica la capacidad de la conexión por 2, 4 u 8 veces.

 

A modo de ejemplo la siguiente tabla muestra la diversidad de asignación de canales en la banda UNII-1 y UNII-2 en 4 dominios regulatorios:

 

Frecuencias y canales WIFI

 

Comparación entre 2,4 GHz y 5 GHz

 

Las señales en la banda de 2,4 GHz tienen mayor alcance y mejor propagación a través de obstáculos, pero por otro lado muchos dispositivos utilizan esta frecuencia y con mayor posibilidad de sufrir interferencias, además de tener una cantidad muy limitada de canales que se superponen.

 

Por otro lado, el espectro de 5 GHz está menos ocupado y cuenta con un número mayor de canales no superpuestos. Existen dispositivos antiguos que no cuentan con una radio dual, es decir que soporten 2,4 y 5 GHz, lo que hace que no puedan operar en la frecuencia de 5 GHz.

 

Por otra parte, en la frecuencia de 5 GHz, la señal es más débil de menor alcance y penetración, con una propagación más limitada, además no se trata de una frecuencia completamente libre de interferencias ya que los radares meteorológicos y de aeronavegación pueden funcionar en algunas bandas de esta frecuencia.

 

Si quieres aprender a como configurar un Wireless Router en Cisco Packet Tracer puedes ver el siguiente video artículo

 

Y si quieres realizar la Configuración de Wireless LAN Controller WLC y Lightweight Access Point Cisco, te invito a ver el siguiente video artículo

Abrir chat
Hola 👋, en que puedo ayudarte!