Las rutas estáticas tienen una distancia administrativa de 1, como se ve en la siguiente figura:

 

Ruta estática flotante para el CCNA

 

 

Como se ve en la figura anterior, los protocolos dinámicos tienen una mayor distancia administrativa que una ruta estática, esto significa en la práctica, que un router va a preferir una ruta estática sobre una ruta que aprendió por medio de un protocolo de enrutamiento dinámico.

 

Para recordar, los protocolos de enrutamiento dinámicos son:

  • RIP
  • IGRP
  • OSPF
  • IS-IS
  • EIGRP
  • BGP

 

Si queremos usar una ruta estática, como ruta de respaldo, tendremos que cambiar su distancia administrativa. A esto se llama una ruta estática flotante.

Veamos un ejemplo, donde R1 puede usar R2 o R3 para llegar a la red 192.168.2.0/24:

 

 

Ruta estática flotante para el CCNA

 

 

R1

router eigrp 100

 network 192.168.0.0

 

R2

router eigrp 100

 network 192.168.0.0

 network 192.168.2.0

 

R1 puede llegar a la red 192.168.2.0 por medio de R2:

R1#sh ip route | begin 192.168.2.0

D    192.168.2.0/24 [90/3072] via 192.168.0.2, 06:57:13, GigabitEthernet0/1

 

¿Ahora qué pasa si queremos usar R3 como respaldo?, R3 no tiene ningún protocolo de enrutamiento, por lo que debemos usar una ruta estática. Esta es una posibilidad cuando el router está fuera de su control.

 

Entonces configuramos una ruta estática para llegar a la red 192.168.2.0/24 a través de R3:

 

R1(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.3

 

Mirando la tabla de ruta encontramos lo siguiente:

 

R1#sh ip route | begin 192.168.2.0

S    192.168.2.0/24 [1/0] via 192.168.1.3

 

Debido a la menor distancia administrativa, nuestra ruta EIGRP ahora se ha ido. Esto es por la distancia administrativa de EIGRP que es 90, y la distancia administrativa de la ruta estática es de 1, por lo que en la tabla de ruta queda la menor distancia administrativa, es decir 1

 

Ahora es cuando podemos manipular la distancia administrativa de una ruta estática como sigue:

Primero eliminamos la ruta creada

 

R1(config)# no ip route 192.168.2.0 255.255.255.0 192.168.1.3

 

Y creamos la siguiente ruta estática flotante:

 

R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.3 ?

  <1-255>  Distance metric for this route

 

R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.3 91

 

Pusimos el número 91 que tiene que ser mayor a la distancia administrativa de EIGRP que es 90

 

Ahora al chequear la tabla de ruteo vemos que ha vuelto la ruta EIGRP

R1#sh ip route | begin 192.168.2.0

D    192.168.2.0/24 [90/3072] via 192.168.0.2, 07:12:49, GigabitEthernet0/1

 

La ruta estática todavía está detrás de escena, esperando que falle la ruta EIGRP para aparecer en la tabla de ruta, como se muestra haciendo la siguiente prueba:

 

Bajamos la intefaz G0/1 de R2

R2(config)#interface GigabitEthernet 0/1

R2(config-if)# shutdown

 

Al ver la tabla de ruta, revive la ruta estática flotante:

R1#sh ip route | begin 192.168.2.0

S    192.168.2.0/24 [91/0] via 192.168.1.3

 

Configuraciones de R1, R2 y R3

R1

interface GigabitEthernet0/1

ip address 192.168.0.1 255.255.255.0

!

interface GigabitEthernet0/2

ip address 192.168.1.1 255.255.255.0

!

router eigrp 100

network 192.168.0.0

!

ip route 192.168.2.0 255.255.255.0 192.168.1.3 91

 

R2

interface GigabitEthernet0/1

ip address 192.168.0.2 255.255.255.0

!

interface GigabitEthernet0/2

ip address 192.168.2.2 255.255.255.0

!

router eigrp 100

network 192.168.0.0

network 192.168.2.0

 

R3

interface GigabitEthernet0/1

ip address 192.168.1.3 255.255.255.0

!

interface GigabitEthernet0/2

ip address 192.168.2.3 255.255.255.0

 

Si quieres realizar prácticas de Configuración para el examen CCNA, te invito al curso “Cisco CCNA 200-125: Prácticas de configuración en español