Seleccionar página

Secure Shell (SSH) es un protocolo que proporciona acceso remoto seguro a dispositivos de la red. La comunicación entre el cliente es encriptado con el protocolo SSH, evitando que terceras persona puedan descubrir el usuario y contraseña ni lo que se escribe durante toda la sesión.

SSH trabaja de manera similar a Telnet, con la gran diferencia, que Telnet es un protocolo no seguro, el cuál que por medio de técnicas de sniffer se puede descubrir su usuario y contraseña, esto debido a que Telnet envía toda la data en texto plano, totalmente elegible para ser leído por cualquier atacante.

Por lo tanto la recomendación es usar siempre SSH en toda comunicación entre cliente y servidor (Servidor, Switch, Router, etc.)

Puedes ver un video de configuración en la siguiente línea:

 

 

 

 

También les dejo un archivo descargable para ejercitar la configuración del laboratorio, requiere de Cisco Packet Tracer 7.0 para ver el archivo 

Archivo de Actividad SSH en Packet Tracer 7.0

https://1drv.ms/u/s!AkbKKrpW2ASWjmI1dzPTp-CUpUso

 

 

 

Para la configuración de SSH debemos seguir los siguientes pasos

Configuración de PC

Paso 1: Configuración de IP

IP Address:                        192.168.0.100

Subnet Mask:                    255.255.255.0

Default Gateway:            192.168.0.1

eclassvirtual-ssh-02

eclassvirtual-ssh-02

 

Habilitar SSH en Switch Cisco

Paso 1: Configuración de IP de administración

Switch#conf t

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.0.10 255.255.255.0

Switch(config-if)#no shutdown

Paso 2: Configuración de default Gateway apuntando al Router

Switch(config)#ip default-gateway 192.168.0.1

Paso 3: Configuración de hostname y nombre de dominio

Switch(config)#hostname eclassvirtual-sw

eclassvirtual-sw(config)#ip domain-name eclassvirtual.com

 

Paso 4: Generación de llaves RSA

eclassvirtual-sw(config)# crypto key generate rsa

The name for the keys will be: eclassvirtual-sw.eclassvirtual.com

Choose the size of the key modulus in the range of 360 to 2048 for your

General Purpose Keys.  Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]: 2048

% Generating 2048 bit RSA keys, keys will be non-exportable…[OK]

eclassvirtual-sw(config)#

 

Paso 5: Cambiar SSH versión 1 a la 2 (la versión 2 es más segura)

eclassvirtual-sw(config)#ip ssh version 2

 

Paso 6: Configuración de Line VTY

eclassvirtual-sw(config)# line vty 0 15

eclassvirtual-sw(config-line)# transport input ssh

eclassvirtual-sw(config-line)# login local

 

Paso 7: Crear nombre de usuario y password

eclassvirtual-sw(config)# username eclassvirtual privilege 15 secret cisco123

Paso 8: Habilitar enable secret

eclassvirtual-sw(config)# enable secret cisco123

Paso 9: Realizar pruebas de SSH desde el PC

C:\>ssh -l eclassvirtual 192.168.0.10 Open

Password:

 

Paso 10: Revisión de conexión SSH en el Switch

eclassvirtual-sw# show ssh

Habilitar SSH en Router Cisco

Router#conf t

Router(config)#hostname eclassvirtual-router

eclassvirtual-router(config)#interface g0/0

eclassvirtual-router(config-if)#ip address 192.168.0.1 255.255.255.0

eclassvirtual-router(config-if)#no shutdown

eclassvirtual-router(config-if)#exit

eclassvirtual-router (config)#ip domain-name cisco.com

eclassvirtual-router(config)#username eclassvirtual privilege 15 secret cisco123

eclassvirtual-router(config)#crypto key generate rsa

The name for the keys will be: eclasvirtual-router.cisco.com

Choose the size of the key modulus in the range of 360 to 2048 for your

General Purpose Keys. Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]: 2048

% Generating 2048 bit RSA keys, keys will be non-exportable…[OK]

eclassvirtual-router(config)#

eclassvirtual-router(config)#ip ssh version 2

eclassvirtual-router(config)#enable secret cisco123

eclassvirtual-router(config)#line vty 0 15

eclassvirtual-router(config-line)#transport input ssh

eclassvirtual-router(config-line)#login local

eclassvirtual-router#show ip ssh

C:\>ssh -l eclassvirtual 192.168.0.1 Open

Password: