Seleccionar página

 

 1.      Introducción

 

A veces se requiere saber en qué puerto de un switch está conectado un dispositivo de red, por ejemplo, una PC.

Para esto podemos usar una serie de comandos Cisco para encontrar a este dispositivo de red, que puede ser una PC, una impresora, un Servidor, otro switch, etc.

 

2.      Red Topológica

 

Como ejemplo usamos la red donde se requiere saber en que puerto del “Switch0” (en realidad puede ser en cualquier switch de la red) está conectado el “PC0”

Para esto se requiere tener configurado la administración remota de los switch en cuestión, que en nuestro ejemplo son switch de la marca Cisco.

Configuración de “Multilayer-Switch0”

hostname Multilayer-Switch0

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

ip routing

!

spanning-tree mode pvst

!

interface FastEthernet0/1

no switchport

ip address 20.20.20.1 255.255.255.0

!

interface FastEthernet0/2

no switchport

ip address 10.10.10.1 255.255.255.0

!

line vty 0 4

password cisco

login

 

 

Configuración de Switch0

hostname Switch0

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface Vlan1

ip address 10.10.10.2 255.255.255.0

!

ip default-gateway 10.10.10.1

!

line vty 0 4

password cisco

login

line vty 5 15

login

 

Configuración de PC0

 

Configuración de Laptop0

 

3.      Encontrando el puerto de Switch

 

Desde el Laptop0, nos conectamos a “Multilayer-Switch0”

C:\>telnet 10.10.10.1

Trying 10.10.10.1 …Open

User Access Verification

Password:

Multilayer-Switch0>ena

Password:

Multilayer-Switch0#ping 10.10.10.100

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.100, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

 

Multilayer-Switch0#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.10.10.1              –   0030.A3BB.7402  ARPA   FastEthernet0/2

Internet  10.10.10.2              45  0030.F26D.DE11  ARPA   FastEthernet0/2

Internet  10.10.10.100            45  0000.0CB9.C5ED  ARPA   FastEthernet0/2

Internet  20.20.20.1              –   0030.A3BB.7401  ARPA   FastEthernet0/1

Internet  20.20.20.100            45  0001.429C.CE5E  ARPA   FastEthernet0/1

Multilayer-Switch0#sh cdp n det

 

Device ID: Switch0

Entry address(es):

IP address : 10.10.10.2

Platform: cisco 2960, Capabilities: Switch

Interface: FastEthernet0/2, Port ID (outgoing port): FastEthernet0/1

Holdtime: 177

 

Version :

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Wed 12-Oct-05 22:05 by pt_team

 

advertisement version: 2

Duplex: full

 

Multilayer-Switch0#

Multilayer-Switch0#10.10.10.2

Trying 10.10.10.2 …Open

User Access Verification

Password:

Switch0>ena

Password:

Switch0#ping 10.10.10.100

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.100, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

 

Switch0#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.10.10.1              46  0030.A3BB.7402  ARPA   Vlan1

Internet  10.10.10.2              –   0030.F26D.DE11  ARPA   Vlan1

Internet  10.10.10.100            47  0000.0CB9.C5ED  ARPA   Vlan1

 

Switch0#sh mac address-table

Mac Address Table

——————————————-

 

Vlan    Mac Address       Type        Ports

—-    ———–       ——–    —–

 

1    0000.0cb9.c5ed    DYNAMIC     Fa0/2

1    0030.a3bb.7402    DYNAMIC     Fa0/1

Switch0#

 

4.      Revisión de comandos

 

“show arp” muestra el mapeo de las direcciones IP a MAC a interfaz del router.

Internet  10.10.10.100            45  0000.0CB9.C5ED  ARPA   FastEthernet0/2

 

“show cdp neighbors detail” muestra la dirección IP de un dispositivo vecino y por cual interfaz ve a este destino.

Device ID: Switch0

Entry address(es):

IP address : 10.10.10.2

Platform: cisco 2960, Capabilities: Switch

Interface: FastEthernet0/2, Port ID (outgoing port): FastEthernet0/1

 

“sh mac address-table” para verificar las entradas de la tabla de direcciones MAC

Mac Address Table

——————————————-

Vlan    Mac Address       Type        Ports

—-    ———–       ——–    —–

   1    0000.0cb9.c5ed    DYNAMIC     Fa0/2

1    0030.a3bb.7402    DYNAMIC     Fa0/1

 

5.      Conclusión

 

Con los comandos mencionados anteriormente, podemos saber por cual puerto de switch esta conectado nuestro dispositivo de red.

En este caso se buscó la dirección IP 10.10.10.100, dando por resultado la dirección MAC 0000.0cb9.c5ed encontrándose en la puerta F0/2 del Switch0

 

 

6.      Vídeo Completo